MCG pro ghost buttons and brake lever not at 0

Moderator: AdminGroup

VirusAM
Posts: 60
Joined: Mon Mar 30, 2020 15:18
Has thanked: 12 times
Been thanked: 1 time

MCG pro ghost buttons and brake lever not at 0

Postby VirusAM » Wed Apr 01, 2020 14:12

Good morning,
i am having some issue with my new (1 month old) gunfighter III with MCG Pro grip and 20cm extension.
Some times i have ghost presses of some buttons when moving the stick. If i remove the stick and grip and put back usually i solve that, but sometimes it rehappens. I have the 2 grip fasteners really thight. I tried without the extension for few minutes and it seems that this issue don't happen (but i should try more).
Today i also did the firmware upgrade to the latest, and i did the calibration, now i have another issue that always happens (also with and without the extension).
The brake lever don't go to 0, if i press it all the way it goes to 65355 normally, but when i leave it return to the same value (6) (see picture).
Then if i move the stick, it moves (without me touching the brake lever) between 0 and 6.
I tried multiple times to redo the calibration (hoping it would just be a calibration issue) but the situation don't change.
I hope it is some bug in the new firmware and that my unit is not broken.
Also (for now) after the new calibration the "ghost" buttons issue seems to don't happen.

EDIT: the ghost buttons involved virtual keys in the brake lever and folding trigger....i add that in order to specify better and let you understand which might be the problem

Capture.PNG


thanks anyone for any reply.

Ron61
Posts: 1986
Joined: Tue Jan 15, 2013 23:56
Location: г.Минск
Has thanked: 37 times
Been thanked: 417 times

Re: MCG pro ghost buttons and brake lever not at 0

Postby Ron61 » Wed Apr 01, 2020 14:48

Firstly, it is worth observing the simple rule of matching firmware versions and the configurator. This is evidenced by the line in brackets at the very top of the configurator window. The recommended firmware version (1.987) is indicated there. Higher is possible, lower is not.
Secondly, the triggered 30 button is reserved for working with the brake lever. But without providing a screenshot of the corresponding tab, it is difficult to understand how it is configured there.
Thirdly, if the axis is not calibrated or calibrated not by concept, then such errors are possible.
Therefore, provide more screenshots of the tabs. So it will be easier to understand where the error crept in the settings.

VirusAM
Posts: 60
Joined: Mon Mar 30, 2020 15:18
Has thanked: 12 times
Been thanked: 1 time

Re: MCG pro ghost buttons and brake lever not at 0

Postby VirusAM » Wed Apr 01, 2020 15:37

Thanks for the reply.
About the firmware i don't understand what you say.
Just today i updated to the latest version avaliable on the vkb site (1.98.6) now you say to update to 1.98.7 but if not on the official page where i should find it?
Also today i downloaded the latest programming software version....which on the same site is 0.91.15 i don't understand which version mismatch you say.
Capture.PNG

About the triggered button, it seems to don't happen anymore, and yes i programmed dx30 to the brake lever (and also dx24 to trigger medium and dx28 to trigger up).
Here is a screenshots that you requested.
Capture2.PNG
Capture3.PNG

But my main problem is not the ghost buttons (it seems disappered for now) but that the brake lever gives strange readings as i wrote in the first post, without me touching it reads 6 out of 65535, while if i move the stick it moves between 0 and 6.
If i lower the axis precision from 15 bit to 13 the problem disappears. It is normal or do i have an issue with my hardware/software?

Ron61
Posts: 1986
Joined: Tue Jan 15, 2013 23:56
Location: г.Минск
Has thanked: 37 times
Been thanked: 417 times

Re: MCG pro ghost buttons and brake lever not at 0

Postby Ron61 » Wed Apr 01, 2020 16:16

I'm talking about this discrepancy.
v..jpg

Everything extreme is here.
Do not change the bit depth of the axis - this will not achieve anything good. Only a headache, your example confirms this.

VirusAM
Posts: 60
Joined: Mon Mar 30, 2020 15:18
Has thanked: 12 times
Been thanked: 1 time

Re: MCG pro ghost buttons and brake lever not at 0

Postby VirusAM » Fri Apr 03, 2020 21:43

Thanks, but I prefer to stay with official released and stable firmware.
About the axis depth I understand, from reading the technical sheet, that all the axis are 16bit (but only 15 are selectable i know that and i also read why it is so) so why I cannot select 15 bit for precision of the axis?


Return to “Manuals and Howtos”

Who is online

Users browsing this forum: No registered users and 1 guest