Solving errors for New Blackbox GF.III fimeware flashing

Moderator: AdminGroup

wotao
Posts: 1
Joined: Sat Feb 29, 2020 22:19
Been thanked: 4 times

Solving errors for New Blackbox GF.III fimeware flashing

Postby wotao » Sat Feb 29, 2020 22:28

I was trying to flash a new firmware version for my GF.III SCG, which comes with the new "black" blackbox, and encountered the infamous messages of error reading and error writing.

I found none of the solutions in the previous posts worked. They include trying to connect/disconnect USB, removing something from Device Managers, trying older versions of ZBootloader-C.exe, trying another computer, and dealing with some jumpers.

What finally worked for me is to boot my Windows 10 (latest version) into "Safe Mode", disconnect USB, open ZBootloader-C.exe, connect USB while holding the SYS button on the blackbox. Just report so you guys know.

User avatar
rrohde
Posts: 615
Joined: Thu Oct 08, 2015 9:28
Location: USA
Has thanked: 680 times
Been thanked: 235 times

Re: Solving errors for New Blackbox GF.III fimeware flashing

Postby rrohde » Mon Mar 02, 2020 22:18

Thanks for sharing your workaround for those who might find themselves in a similar situation.

Just to say - this is not the norm. I have flashed multiple Gunfighter BlackBoxes, orange ones - and the new black ones - using various different sets of firmware with no issues whatsoever, on Windows 10. Wonder what might have caused this in your case...

Also, as a reminder: when receiving a brand new Gunfighter Mk.III, there's typically no real need to flash the firmware as VKB HQ already uses stable firmware before they ship out each Gunfighter, and everything should work out-of-the-box. That said, firmware updates are usually only recommended if VKB HQ identifies some issues with that default firmware (and they release an improved version), or you're swapping between grips (as each grip requires a specific firmware to be used. ...until the multi-device next gen firmware is ready for all of us - but that's another story).
VKB North America
https://VKBcontrollers.com

Daedalus
Posts: 1
Joined: Tue Mar 03, 2020 1:39
Has thanked: 2 times
Been thanked: 1 time

Re: Solving errors for New Blackbox GF.III fimeware flashing

Postby Daedalus » Wed Mar 04, 2020 1:21

Thanks for sharing Woto, this was an island in my desperation.
However, if this still doesn't work for someone and you've arrived here like me... try checking the USB cable from blackbox to PC, or potentially that the grip/extension is seated properly.

I'd a dead black box not lighting up or being recognised by windows, on a brand new Gunfighter MK3 with MCG pro.
After 3 days of searching through links to find relevant manuals/how tos, and trying everything under the sun. I finally resolved my problem as being a faulty USB cable!...
The VKB branded USB cable that came with joystick would only connect for a moment when holding it at an angle (discovered while trying different USB ports). Replaced with a decent quality cable and instantly had no issues.
I'm surprised at the cable quality/ quality control on a product at this price point and this level of engineering. Confusing/scattered information was somewhat understandable with a pro-sumer product, but not issues with readily available basic hardware elements.
Besides that I'm very happy with the stick, and excited to finally get flying with it!!!... hope this helps someone.

PS... the button on the new (black) blackbox is a clever new replacement for shorting the boot jumpers as mentioned in manuals and other posts.


Return to “Manuals and Howtos”

Who is online

Users browsing this forum: No registered users and 1 guest