Gladiator NXT EVO L & R + SEM = No sliders/throttle wheel at Joysticks [Solved]

Moderator: AdminGroup

PryingMantis
Posts: 24
Joined: Thu Sep 21, 2023 0:39
Has thanked: 8 times
Been thanked: 2 times

Re: Gladiator NXT EVO L & R + SEM = No sliders/throttle wheel at Joysticks [Solved]

Postby PryingMantis » Thu Sep 28, 2023 18:40

Totally understand that, Fallout. We all make mistakes. I don't fault VKB for that. How we treat people on the receiving end of our mistakes is more the point. How senior members of a community, employees or otherwise who are more knowledgeable than others, treat those seeking assistance, is also the point. Perhaps Ron is a super helpful guy, but when you start belittling people who are trying to find the solution to their problems, and/or acting as if they should know all these things, or they are bothering you by asking for help getting their product to function, it is unproductive, demeaning, and unnecessary behavior.

As someone who has been combing these forums and discord server for the past week and a half trying to resolve the issues I'm having, I would suggest to you that this latest firmware may have had a more significant impact than you recognize. Perhaps my other issues are not related, but many of the things I went through were kicked off with that, and two other issues seem to be lining up with what others have found as well. Perhaps, many of your thousands of users have not tried installing this update. I know it is not my common practice (if it ain't broke, don't fix it), and I only did so because the WWII throttle I installed was not working, and it was suggested that the firmware needed to be updated as part of the process. Something for you to consider anyway.

I will end my exploration of these archives here. I'll await resolution for my issues in the support ticket you recommended for the other issues I have. Thank you.


Return to “Technical Support”

Who is online

Users browsing this forum: Google [Bot] and 6 guests