Bad inputs in Unity input debugger

Moderator: AdminGroup

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Bad inputs in Unity input debugger

Postby radranic » Thu Jun 30, 2022 22:20

I've been trying to figure out a bug in a game written in Unity that seemed to be tripping up the default input binding library for my Gladiator NXT L & R.

It would always report extra input from the stick, hat, and axis in the first event sent when pressing the binding button. The next event would be normal and have the correct button information in it.

It's using: HID::© Alex Oz 2012-2019 VKB-Sim Gladiator NXT L

This:
ButtonNoise.png

is what happens in the event before I pressed Button 11.

I've included a dump from of the log from the unity debugger.

Is this a know issue/something that can be fixed? Old HID driver or firmware?

It doesn't seem to affect gameplay if you can force the binding because of the correct event after, but it causes the Hat Up button to always be detected instead of anything else.

We've found what appears to be a work around for the binding issue, but it would be nice to figure out what's going on with the events so we can remove a bit of weird code that is there only to ignore the weird events.
Attachments
VKB-Sim Gladiator NXT L.zip
(3.13 KiB) Downloaded 11 times

User avatar
fallout9
Posts: 4091
Joined: Wed Oct 03, 2018 20:37
Has thanked: 180 times
Been thanked: 971 times

Re: Bad inputs in Unity input debugger

Postby fallout9 » Thu Jun 30, 2022 23:31

Post 2 screenshots with VKBDevCfg showing 1. Global/External panel and 2. Profile/Axes/Physical Axes.

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Fri Jul 01, 2022 0:02

Global:
LeftProfileAxes.png


Profile Axes:
LeftGlobalExternal.png

User avatar
fallout9
Posts: 4091
Joined: Wed Oct 03, 2018 20:37
Has thanked: 180 times
Been thanked: 971 times

Re: Bad inputs in Unity input debugger

Postby fallout9 » Fri Jul 01, 2022 3:29

Try reflashing to the latest firmware.

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Fri Jul 01, 2022 16:22

I've now got them both running on v2.090 and it still happens sadly.

Ron61
Posts: 2851
Joined: Tue Jan 15, 2013 23:56
Location: г.Минск
Has thanked: 42 times
Been thanked: 567 times

Re: Bad inputs in Unity input debugger

Postby Ron61 » Fri Jul 01, 2022 16:58

See this post, do accordingly.

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Fri Jul 01, 2022 18:19

Ah! Stuff newer than the downloads page. Thanks. Will try as soon as I can.

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Fri Jul 01, 2022 18:53

I ran the config software and flashed the left one and it started throwing errors.

This is what I get in the config now:
LeftFlashed.png



I can't reflash it to something older. Did I just brick my left stick?

Nevermind, closed everything and disconnected it and reconnected and it seems to be acting normal again. Scared me.

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Fri Jul 01, 2022 19:03

Weird inputs still happening.

Currenting being reported as: "HID::VKB-Sim © Alex Oz 2021 VKBsim Gladiator NXT L "

So at least that's updated now. Oddly it's now using that HID descriptor for both sticks despite only reflashing the left for now.

User avatar
fallout9
Posts: 4091
Joined: Wed Oct 03, 2018 20:37
Has thanked: 180 times
Been thanked: 971 times

Re: Bad inputs in Unity input debugger

Postby fallout9 » Fri Jul 01, 2022 20:03

Screenshot of Global/External please.

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Fri Jul 01, 2022 20:08

Here you go:
LeftGlobalExternal92.33.png



Is there any kind of logging/debugging I can enable to get you more information?

Ron61
Posts: 2851
Joined: Tue Jan 15, 2013 23:56
Location: г.Минск
Has thanked: 42 times
Been thanked: 567 times

Re: Bad inputs in Unity input debugger

Postby Ron61 » Fri Jul 01, 2022 21:10

Update the right as well as the left. Is the problem gone?

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Fri Jul 01, 2022 21:20

Just updated the right and it's the same.

Both2.111.png

User avatar
fallout9
Posts: 4091
Joined: Wed Oct 03, 2018 20:37
Has thanked: 180 times
Been thanked: 971 times

Re: Bad inputs in Unity input debugger

Postby fallout9 » Sat Jul 02, 2022 9:48

Just to make sure - you did pressed the Default button after flashing, right?

radranic
Posts: 13
Joined: Thu Jun 30, 2022 22:01

Re: Bad inputs in Unity input debugger

Postby radranic » Sat Jul 02, 2022 15:03

Default then recalibrate each time yes.


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 10 guests