X and Y axis not working Gladiator MKII - Win 10

Moderator: AdminGroup

User avatar
Posts: 1
Joined: Mon Jan 15, 2018 20:39

X and Y axis not working Gladiator MKII - Win 10

Postby switchblade » Mon Jan 15, 2018 23:21

I am unable to configure my new VKB-Gladiator MKII joystick. No matter what I do, the X and Y axis will not move with the movement of the joystick handle. It is like the system thinks I have peddle, when I do not.

I'm running Windows 10 Pro 64bit, 16gb of ram, 4th gen intel i7. My OS is fully patched and I have no other joysticks installed.

The games I will use this joystick are X-Plane 11, MS Flight Sim X, Elite Dangerous, Call of Duty (when flying aircraft), and Far Cry 4. None of these games are working correctly because I have no X and Y axis, or I get weird inputs and cannot control anything.

Windows detected the joystick with no errors. I used ZBootloader-C and updated the joystick firmware to Gl_v1_85_B.

I have WIZZO_v0_88 and it shows movement on all axis. I flipped the switches at the top for X, Y, Yaw, and Throttle. I Start to configure, moved joystick in all positions, including yaw, moved throttle up and down, etc. Then hit Stop and it saves the config and closed wizzo. At this point, the joystick will still not work in any game.

in Windows Devices and Printers, right click on the joystick icon and open Game Controller Settings. Then Properties to bring up the joystick properties. Here is where i see the X and Y box with the + in the box. That moves just fine with the movement of the joystick. However, the red bars do not move. Throttle and yaw work fine, but the red bars for X and Y do not move. I have tried calibrating from here to no avail. When I run the calibration and get to the X and Y, nothing moves, only Yaw and throttle work.

I then ran VKBDevCfg-C_v0_83_9_6 and I get a message saying it detected a windows calibration and recommends to replace it. It adds some registry entries and creates a reg key delete file so you can remove the reg entries later if you want to. In this config tool i can calibrate and test and it all looks good. I Saved the config, etc. Exit and go test in games again. X and Y still do not work correctly, even after running the game config to assign axis and buttons. For example, even though everything looks ok in the games settings, flight will steer me hard right and applying full left barely does anything, as if it needs to be calibrated.

I must be missing something because I have never had a joystick so difficult to just calibrate.

Any ideas on what to try next?

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest