MCG + GLADIATOR PRO not working

Moderator: AdminGroup

scipio72
Posts: 1
Joined: Thu Jan 11, 2018 3:23

MCG + GLADIATOR PRO not working

Postby scipio72 » Thu Jan 11, 2018 3:41

Hello,
I'm trying to get my MCG working on my gladiator pro base. I attached the grip and there is no space between grip and base. When I plug in the usb cable I see a flashing red light. The buttons on the base work and the sensor detects the stick movements fine. However the buttons on the stick don't work. When I launch bootloader from the devcfg it says device recognized but the light on the base turns off and nothing works. I can see under the external tab that MCG is not selected. I've tried selecting it from the dropdown but there is no change when I do. I have tried the bootloader button and the default button in the WIZZO. Any help would be much appreciated.

Thanks

User avatar
AeroGator
Posts: 238
Joined: Wed May 31, 2017 7:40
Has thanked: 56 times
Been thanked: 94 times

Re: MCG + GLADIATOR PRO not working

Postby AeroGator » Thu Jan 11, 2018 6:51

scipio72 wrote:I'm trying to get my MCG working on my gladiator pro base.

Pls check your email inbox.
I guess you pre-ordered the MCG grip for Gladiator Pro and later ignored the message from the shop asking to cancel and re-order the same goods under a different name.
The point of such a reshuffle is that although MCG for GF1 and MCG for GLPro are totally identical mechanically, they need different firmware due to obvious base difference.
You probably did not cancel and re-order, so you received the MCG grip with FW meant to be used with the GF base.
This is no big problem except now you will have to wait till we release the dedicated FW.
Please stay tuned for this FW announcement.
Sorry for the time you lost. FW is being tested these days.
Best Regards,
AeroGator


Return to “Technical Support”

Who is online

Users browsing this forum: LukeFF, Sorbic and 5 guests