MCG + GLADIATOR PRO not working

Moderator: AdminGroup

scipio72
Posts: 16
Joined: Thu Jan 11, 2018 3:23
Been thanked: 1 time

MCG + GLADIATOR PRO not working

Postby scipio72 » Thu Jan 11, 2018 3:41

Hello,
I'm trying to get my MCG working on my gladiator pro base. I attached the grip and there is no space between grip and base. When I plug in the usb cable I see a flashing red light. The buttons on the base work and the sensor detects the stick movements fine. However the buttons on the stick don't work. When I launch bootloader from the devcfg it says device recognized but the light on the base turns off and nothing works. I can see under the external tab that MCG is not selected. I've tried selecting it from the dropdown but there is no change when I do. I have tried the bootloader button and the default button in the WIZZO. Any help would be much appreciated.

Thanks

User avatar
AeroGator
Posts: 306
Joined: Wed May 31, 2017 7:40
Has thanked: 72 times
Been thanked: 133 times

Re: MCG + GLADIATOR PRO not working

Postby AeroGator » Thu Jan 11, 2018 6:51

scipio72 wrote:I'm trying to get my MCG working on my gladiator pro base.

Pls check your email inbox.
I guess you pre-ordered the MCG grip for Gladiator Pro and later ignored the message from the shop asking to cancel and re-order the same goods under a different name.
The point of such a reshuffle is that although MCG for GF1 and MCG for GLPro are totally identical mechanically, they need different firmware due to obvious base difference.
You probably did not cancel and re-order, so you received the MCG grip with FW meant to be used with the GF base.
This is no big problem except now you will have to wait till we release the dedicated FW.
Please stay tuned for this FW announcement.
Sorry for the time you lost. FW is being tested these days.
Best Regards,
AeroGator

JohnSMir
Posts: 4
Joined: Wed Feb 14, 2018 12:31
Has thanked: 1 time

Re: MCG + GLADIATOR PRO not working

Postby JohnSMir » Thu Feb 15, 2018 6:59

Seem like I have the exact same problem

scipio72
Posts: 16
Joined: Thu Jan 11, 2018 3:23
Been thanked: 1 time

Re: MCG + GLADIATOR PRO not working

Postby scipio72 » Sat Feb 24, 2018 20:04

Hello,

Is there any word on firmware that might fix this issue?

Thanks

User avatar
Victorus
Posts: 987
Joined: Wed Sep 21, 2011 13:25
Has thanked: 142 times
Been thanked: 121 times

Re: MCG + GLADIATOR PRO not working

Postby Victorus » Sat Feb 24, 2018 21:43

Please download configuration tool from here https://drive.google.com/drive/folders/0B1WRiD1czmcHMVBEcVQ0dndyNG8?usp=sharing
Launch and show screenshots of Global - External - External devices tab.

scipio72
Posts: 16
Joined: Thu Jan 11, 2018 3:23
Been thanked: 1 time

Re: MCG + GLADIATOR PRO not working

Postby scipio72 » Sat Feb 24, 2018 22:12

Screenshot (2).png

Ron61
Posts: 866
Joined: Tue Jan 15, 2013 23:56
Location: г.Минск
Has thanked: 15 times
Been thanked: 164 times

Re: MCG + GLADIATOR PRO not working

Postby Ron61 » Sun Feb 25, 2018 14:35

Take a screenshot of the window with the Alt key (Alt + PrintScreen), please. On your hard to consider anything.

scipio72
Posts: 16
Joined: Thu Jan 11, 2018 3:23
Been thanked: 1 time

Re: MCG + GLADIATOR PRO not working

Postby scipio72 » Sun Feb 25, 2018 20:24

Untitled.png

User avatar
Victorus
Posts: 987
Joined: Wed Sep 21, 2011 13:25
Has thanked: 142 times
Been thanked: 121 times

Re: MCG + GLADIATOR PRO not working

Postby Victorus » Sun Feb 25, 2018 20:37

[quote="scipio72"][/quote]
Can you see anything at this picture?) Ron is right.
What can I see.
You use obsolete firmware. This firmware intended to Gladiator AS IS, without MCG.
What to do. Download User Guide https://yadi.sk/i/Ye-jvF_j3Skuo5
Download configuration tool https://drive.google.com/open?id=1-gf_gxwpQi-K7WxMX_bbpeovBlSC-_Nj
Download firmware loader https://drive.google.com/open?id=1RDZgS5xyNP6VUJjlVz0HlOxeEKQgZkYz, up-to-date firmware https://drive.google.com/open?id=1XaHl33X_QmzWV9Mvu-GOyqeXhrnTLOI6.
Update firmware, take screenshot and we`ll try to force your joystick to work.

scipio72
Posts: 16
Joined: Thu Jan 11, 2018 3:23
Been thanked: 1 time

Re: MCG + GLADIATOR PRO not working

Postby scipio72 » Sun Feb 25, 2018 22:02

Untitled.png

User avatar
Victorus
Posts: 987
Joined: Wed Sep 21, 2011 13:25
Has thanked: 142 times
Been thanked: 121 times

Re: MCG + GLADIATOR PRO not working

Postby Victorus » Sun Feb 25, 2018 23:11

Yes. Thanks.
Ext_dev.png

I see some differences with mine.
Please find zconfig.ini file in the same folder with VKBDevCfg.exe, add User=Developer string to [User] section
[User]
===========================
User=Developer
and restart program. Will you see additional controls?

scipio72
Posts: 16
Joined: Thu Jan 11, 2018 3:23
Been thanked: 1 time

Re: MCG + GLADIATOR PRO not working

Postby scipio72 » Mon Feb 26, 2018 1:20

Hi
I added the string. Now it looks like this
Untitled.png

User avatar
Victorus
Posts: 987
Joined: Wed Sep 21, 2011 13:25
Has thanked: 142 times
Been thanked: 121 times

Re: MCG + GLADIATOR PRO not working

Postby Victorus » Mon Feb 26, 2018 9:39

Now try to use profile from zip file.
Gladiator_MCG_000.zip
(1.17 KiB) Downloaded 30 times

I think you will see the following image.
Ext_dev_Glad.png

About this profile. Joystick will have 3 Gladiator axes + 5 MCG axes. Thanx to Alex_Oz for this profile.

scipio72
Posts: 16
Joined: Thu Jan 11, 2018 3:23
Been thanked: 1 time

Re: MCG + GLADIATOR PRO not working

Postby scipio72 » Mon Feb 26, 2018 19:45

That did the trick! I think everything is working now. Many thanks to everyone who helped :D

User avatar
Victorus
Posts: 987
Joined: Wed Sep 21, 2011 13:25
Has thanked: 142 times
Been thanked: 121 times

Re: MCG + GLADIATOR PRO not working

Postby Victorus » Mon Feb 26, 2018 20:00

Congratulations!


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests