Having MCG Pro Issues, random intermittent button presses

Moderator: AdminGroup

Qyv10
Posts: 13
Joined: Wed Jan 10, 2018 18:08

Re: Having MCG Pro Issues, random intermittent button presses

Postby Qyv10 » Mon Jan 15, 2018 2:28

So I managed to fix 1 problem although it shouldn't be a problem.
Somehow my warthog throttle is interfering with the stick. Specifically 1 button #23 which on mine is the front 5 way push IN button. I had my SCB's mapped to that.
Now in game while in combat I use the thrusters (index finger 4 way hat) A LOT and the SCB's were firing while I was using the thrusters randomly. I remapped then SCB's to the push forward button on the same 5 way and is good now.

Still having the button 14(thumb 5 way UP) activating intermittently while pressing/holding button 4 (RED). See Jake's pic above. Same buttons but different numbers.

User avatar
AeroGator
Posts: 397
Joined: Wed May 31, 2017 7:40
Has thanked: 98 times
Been thanked: 155 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby AeroGator » Mon Jan 15, 2018 5:39

SpaceJake wrote:Ha!

Qyv10 wrote:BUT

Guys I sent both of you PMs and re-sent them this morning. Please check.
We're asking you to run some tests (link to testing soft included) and reply to me via PM.
Thanks!
Best Regards,
AeroGator

User avatar
UIV
Мастер
Posts: 4905
Joined: Mon Apr 17, 2006 16:33
Has thanked: 19 times
Been thanked: 260 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby UIV » Mon Jan 15, 2018 14:54


Qyv10
Posts: 13
Joined: Wed Jan 10, 2018 18:08

Re: Having MCG Pro Issues, random intermittent button presses

Postby Qyv10 » Wed Jan 17, 2018 1:36

UIV, I sent you a PM but not sure you got it as it's not showing in my PM folder.
If not let me know and I'll resend. Thx

User avatar
UIV
Мастер
Posts: 4905
Joined: Mon Apr 17, 2006 16:33
Has thanked: 19 times
Been thanked: 260 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby UIV » Wed Jan 17, 2018 2:55

My box is empty.

Qyv10
Posts: 13
Joined: Wed Jan 10, 2018 18:08

Re: Having MCG Pro Issues, random intermittent button presses

Postby Qyv10 » Wed Jan 17, 2018 6:08

Ok. I resent. It's in my outbox so hopefully it went this time.

User avatar
UIV
Мастер
Posts: 4905
Joined: Mon Apr 17, 2006 16:33
Has thanked: 19 times
Been thanked: 260 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby UIV » Wed Jan 17, 2018 6:17

Please, upload here a screenshot from vkbdevcfg-c with buttons log.
rer.JPG

Qyv10
Posts: 13
Joined: Wed Jan 10, 2018 18:08

Re: Having MCG Pro Issues, random intermittent button presses

Postby Qyv10 » Wed Jan 17, 2018 7:04

I sent 4 to aerogator which are from 1.91E. F shows the same but much better.

User avatar
UIV
Мастер
Posts: 4905
Joined: Mon Apr 17, 2006 16:33
Has thanked: 19 times
Been thanked: 260 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby UIV » Wed Jan 17, 2018 7:27

Please, try to make the screenshots from 1.91.F
Have a difference in FW. Only buttons log from latest firmware can help us to solve the problem.
Thank you.

squeesh
Posts: 1
Joined: Wed Dec 14, 2016 17:50

Re: Having MCG Pro Issues, random intermittent button presses

Postby squeesh » Wed May 23, 2018 6:28

I am having the Red button (4) -> button 14 phantom intermittent button press issue as well on my MCG Pro (3 pin). I've tried firmware 1.92.1 which does not fix the issue. Is there a known fix for this?

User avatar
UIV
Мастер
Posts: 4905
Joined: Mon Apr 17, 2006 16:33
Has thanked: 19 times
Been thanked: 260 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby UIV » Wed May 23, 2018 8:26

Can you provide to us screenshots from VkbDevCFG?

henrytanner
Posts: 2
Joined: Wed May 09, 2018 17:40

Re: Having MCG Pro Issues, random intermittent button presses

Postby henrytanner » Wed May 23, 2018 14:08

i had issues with random break lever activations when moving the stick. after i reseated the stick on the base this issue was gone. i think i didnt tighten the stick enough and the pins on the stick were losing connection when moving it.
i havent had this problem again since

User avatar
UIV
Мастер
Posts: 4905
Joined: Mon Apr 17, 2006 16:33
Has thanked: 19 times
Been thanked: 260 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby UIV » Fri May 25, 2018 2:38

I think you have correctly identified the problem. The base lost contact with the grip.

jacyo
Posts: 8
Joined: Sun Jul 22, 2018 11:34

Re: Having MCG Pro Issues, random intermittent button presses

Postby jacyo » Sun Jul 22, 2018 20:48

I have a similar issue too for my MCG Pro + stick extension. Here are some of my issues:
1. When I move the stick, sometimes button #18 (the push in button of the 4 way switch below the POV ministick) and button # 23 (the push in button of the 4 way switch at the front right of the grip) will activate intermittently
2. It is more rare to happen but button #9 (the push in button of the 4 way switch on the thumb position) and pov 1 (I believe down position) will also activate intermittently
3. On releasing the button #4 (the red button), button #14 (the up position of the 4 way switch below the POV ministick) sometimes will activate
4. In a rare occasion, even without moving the joystick, by just leaving the stick in close to centre position, #18, #23 and #9 button will just continue to activate intermittently

I have followed the steps from https://vkbcontrollers.com/?p=15551 to flash, reset and calibrate the stick, I have also tighten up all the screws but the problems above still exist.

Gunfighter 3-pin Rev.A base
MCG Pro + stick extension
#50 spring
VKB Device Config v0.87.05
Firmware v1.92.1
Attachments
button_triggered_by_idle_joystick.jpg
Issue no.4
buttons_triggered_by_moving_the_joystick.jpg
Issue no.1 and no.2
button_14_triggered_by_red_button_release.jpg
Issue no.3

Ron61
Posts: 978
Joined: Tue Jan 15, 2013 23:56
Location: г.Минск
Has thanked: 18 times
Been thanked: 183 times

Re: Having MCG Pro Issues, random intermittent button presses

Postby Ron61 » Sun Jul 22, 2018 23:19

Try a newer firmware and configurator, take here and here. Carefully, do not confuse the device.


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 3 guests