Page 1 of 4

Having MCG Pro Issues, random intermittent button presses

Posted: Wed Jan 10, 2018 18:48
by Qyv10
This is a copy/cross post from my thread on the hotas subreddit.

History: I have a gunfighter base mk I that I originally got as a replacement for the warthog. I have been using the base with the warthog grip and adapter for some time playing Elite Dangerous with no issues.

Got the MCG Pro grip 2 days ago, had the "getting it working" issues that some have had but got it working. (Flash to default then to MCG Pro)

Yesterday I setup the binds in Elite and started playing to get used to the new grip as it is significantly different from the warthog.

Suddenly I start getting random things happening that are tied to buttons on the grip. UI switching views, SCB's firing, gear up/down, weapons deploying by themselves. That kind of thing. Reset and re flashed several times to no avail.

When I reinstalled the warthog grip all is normal again. Before the GF base my warthog base was doing this as well and I found a loose wire in the base that I re soldered and fixed the issue.

I'm wondering if anybody has seen this issue and has a fix. At this point it's either return it or open it up. I'm leery about opening it and negating the return possibility.

Any advice would help.

EDIT: to add some testing info. Been playing around with it again and noticed an odd thing. In checking the buttons when I hit the red fire button, top left, in the software it lights up BOTH number 4 and 14. HOWEVER while holding the button and if I move the stick around button 14 will turn off/on intermittently.

This makes me lean even more to a loose wire inside and could be my problem if it is giving unregistered input to the game.

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Thu Jan 11, 2018 0:42
by SpaceJake
Yep, having same issue again, upgraded firmware which I thought fixed it.

Button 15 [Red] and button 1 [centre button on rightside hatswitch]
Move stick while holding button 15, buttons 13 and 21 activate intermittently.

Gunfighter Mk1
Mcp Pro [original 3pin]
BB firmware 1.917
VkbConfig software 0.83.85

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Thu Jan 11, 2018 1:08
by Qyv10
Been playing with this thing all day wasting my day off to no avail.

Moved it around in different USB ports, I tried disabling button 14 in the VKBDev software. Thought I had it cuz I got about 10 minutes of play in then started doing it again Grrr.
Had to reset my binds several times with all the switching and such.

At this point I'm pretty much done and am going to ask for a return. Hate to do it but I'm at a loss.

Bug found, fixed FW on the way

Posted: Thu Jan 11, 2018 14:32
by AeroGator
Qyv10 wrote:Been playing with this thing all day wasting my day off to no avail

SpaceJake wrote:Yep, having same issue again

REGARDLESS your individual settings:
:arrow: A bug was found in the current FW that allowed this to happen in many different setups (hence no need to post up screenshots).
We have combed it out and are currently testing the debugged version. A day-two-tops-three later it will be uploaded to our ftp.
So please bear some time. Sorry boys, our fault.

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Fri Jan 12, 2018 1:42
by SpaceJake
Apologies but my original post from Jan 4 with pics included was moved to unclutter the forum.

viewtopic.php?f=25&t=2885#p28622

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Fri Jan 12, 2018 3:33
by Qyv10
Thanks for the heads up. I'll wait for it to come out and see what happens.

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Fri Jan 12, 2018 6:36
by AeroGator
SpaceJake wrote:my original post from Jan 4 with pics included was moved
Yeah quite a mess recently... sometimes I'm adding to it :(

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Fri Jan 12, 2018 7:56
by AeroGator
The new FW has just been released, hurry to get it boys before others do!
(see Announcements section)
And tell me how it works.

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Sat Jan 13, 2018 0:53
by SpaceJake
Buttons still activating intermittently after latest firmware upgrade [1.917]

Button 15 [Red] and button 1 [centre button on rightside hatswitch]
Move stick while holding button 15, button 13 activates intermittently.

Gunfighter Mk1
Mcp Pro [original 3pin]
BB firmware 1.91E
VkbConfig software 0.83.96

Edit - BB Firmware version.

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Sat Jan 13, 2018 5:26
by Qyv10
Hi, I'm still having some issues as well HOWEVER they are nowhere as bad as it was.
I'm still getting the same as Jake, 2 buttons activating on 1 but mine are same as before button 4 and 14. 4 being the top left red button and 14 is intermittent within the VKBDev software and in game. I will try deactivating button 14 again and see what happens. The other one that was still activating was my landing gear kept deploying during combat, I think because I had it tied to the brake lever.
Was on that same lever on my warthog grip but that was a lever activated button not an axis. Probably have to play with the axis2button stuff.

Other then that it's working much better now. Not too sure on the ergonomics of it for me yet. That thumb hat is quite hard for me to use. My thumbs are weird cuz the first joint bends mostly backward, just a little bit forward.

If/when the do some redesigning on this thing use a bit stronger spring on the 2 stage trigger. There is almost no separation between button 1 and button 2. Feels almost like a 2 stage trigger on a rifle. There is a lot of room between touching it and the first button activation. Could easily put in a slightly stronger spring so it activates sooner with more travel before button 2 hits.

Edit: forgot the info

Gunfighter Mk1
MCG Pro [original 3pin]
BB firmware 1.91E
VkbConfig software 0.83.9.6

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Sat Jan 13, 2018 8:25
by UIV
Please, upload here your profiles from VKBDevcfg-C
- Run VKBDevcfg-C
- Click on the joystick name
- Click on the SAVE button and save "cfg" file
- Zip the cfg file and post here
Thank you

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Sat Jan 13, 2018 9:17
by SpaceJake
I re-calibrated a couple of times, no changes...then disconnected base from BB [base end], started VkgConfig then closed VkbConfig, reconnected base and recalibrated.

Seems to be working ok.

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Sun Jan 14, 2018 1:02
by Qyv10
UIV, here is a copy of my .cfg file.
I tried Jake's suggestion real quick but didn't seem to matter. Still getting button 14 (POV up) activating intermittently while button 4 (RED) is held and the stick moved around. Does not activate 14 in any specific spot or general area. Can be any where within the X and/or Y axis travel.

VKB Elite_FAO_1.zip
(1.17 KiB) Downloaded 27 times

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Sun Jan 14, 2018 3:10
by SpaceJake
"Seems to be working ok" Ha!

When opening VkbConfig initial press of the red button 15 activates button 1 for a couple of presses then it works ok.
Close Vkbconfig and restart Vkbconfig and sometimes I get the intermittent problem but only on initial button test.
Moving stick gets "one" intermittent button activation [between 15 and 1], then its ok.

GF_B1_B15.PNG


I dont know, sometimes its ok and sometimes its not.

I have matched the button numbers in the logical layer by unchecking "auto" for all buttons except button 23 in the button wizard.
Pretty sure its the same buttons as Qyv10.

VKB NJoy32 PRO profile SJ.rar
(1.09 KiB) Downloaded 25 times

Re: Having MCG Pro Issues, random intermittent button presses

Posted: Sun Jan 14, 2018 3:48
by Qyv10
SpaceJake, yes it's the same physical buttons but different numbers. Seems kinda odd but what ever. Red button and thumb hat up same as your pic.

UIV, I have confirmed it is still doing it in game as well BUT this is the only issue. No more other things happening.

Also managed to setup up the flip trigger as a 2 stage and works perfectly. Much better then the normal 2 stage. The normal one has almost no travel between 1st and 2nd stages. During heat of combat can barely tell the difference. Definitely needs a stronger spring so it activates earlier to gain more travel between them.

Thanks for all the hard work :)