MCG Pro - mapping ministick and brake axes

Moderator: AdminGroup

Delynne
Posts: 2
Joined: Wed Jan 03, 2018 5:31
Been thanked: 1 time

MCG Pro - mapping ministick and brake axes

Postby Delynne » Wed Jan 03, 2018 5:35

Hi all,

I just got my MCG Pro for my Gunfighter, and I'm trying to set it up, but I'm having issues - I can't seem to get the system to recognize the additional axes. I can enable them in the VKB Device Config tool, and they appear in Windows, but no movement on the ministicks or the brake lever allow them to do anything.

I've found the instructions here on how to make them bind as buttons, but I was hoping for some analog controls. Anybody have any idea why I can't seem to enable them?

I have the Gunfighter Mk 1 version, if that helps at all.

Thanks,
Delynne

mahoffm2
Posts: 4
Joined: Wed Jan 03, 2018 6:14

Gunfighter MCG pro Help needed

Postby mahoffm2 » Wed Jan 03, 2018 6:26

I am having a hard time figuring out the gunfighter pro software. The new Wizzo software won't recognize my gunfighter pro. The VKBDevCfg-C software does not seem to recognize my MCP pro hats or other axes, just the base axis. The games I play only seem to recognize the base axis as well. I think the firmware is out of date, so I downloaded the latest version, but I have no Idea how to install it. There does not seem to be much in the way of manuals or support.

Any support would be much appreciated.

mahoffm2
Posts: 4
Joined: Wed Jan 03, 2018 6:14

Re: Gunfighter MCG pro Help needed

Postby mahoffm2 » Wed Jan 03, 2018 6:59

I figured out how to update firmware, still can not find hat switches and other axes or run wizzo. Also can not get the pinky button to work.

Drano
Posts: 47
Joined: Sun Oct 01, 2017 5:00
Location: USA, East coast
Has thanked: 1 time
Been thanked: 8 times

Flashing red BB Stick LED w/ MCG-Pro grip

Postby Drano » Wed Jan 03, 2018 7:17

Well the long wait was over today and I've been messing with trying to set up the stick and I'm running into a problem with devcfg not seeing the MCG grip. It sees the gunfighter base but shows a KG-12 grip connected to it (which I never had). Changing it to the MCG in devcfg has no effect as it shows a KG-12 again on restart. On the Blackbox I have a solid blue light on "sys", no light on "bus", no light on"pedals" (none connected) and a flashing red light on "stick". A quick search said that was an indication the stick wasn't seated properly so I re-seated the stick. Couldn't be that easy now could it! :mrgreen: . I actually looked to make sure I had a Rev. A MCG to go with my Rev. A gunfighter base and they're right, of course. It looks like all 3 pins on the base have made contact with the inside contacts on the grip as they should (little mark on them). I tried loosening the lock nut on the grip and wiggled it left and right but that didn't help. I tried re-seating the 4-pin connector from the gunfighter to the blackbox at both ends. Tried switching them around. No luck. I thought maybe there was a loose connector inside. Nope. They all look good at least. With the stick open on it's side looking from the bottom end I can see a steady red LED on the PCB where the 3 connectors are. I've downloaded fresh software so everything is up to date. The Wizzo for gunfighter won't do anything as it shows an error communicating with the stick and just closes on acknowledging the error. The devcfg will see the base just fine. I tried a calibration but without seeing the axii on the stick they didn't "stick". Joytester shows the X and Y axii normally but nothing else. I've tried re-starting it via devcfg and rebooting the PC. Comes right back to the flashing red LED on the blackbox. I thought maybe it wasn't communicating properly because it seems to think there's a KG-12 grip attached to it? Gotta be something silly. I've been reading the NJoy32 manual recently translated but it's dated March with no mention of the MCG grips. Hopefully I've just missed something.

OTOH I hope this one isn't a dud. :( The wait was a long one and it's dead sexy! Can wait to get flying with it. Please help!

Thanks!

OK the info:
Gunfighter Rev.A (with the 3 pins)
MCG-Pro Rev.A (with the 3 flats)
Firmware : 1.85F
Springs and Cams are stock. Haven't gotten that far yet!
VKBdevcfg :83_8_5 (newest)

Not sure the other items are relevant but will hit ya with them if needed.
Gunfighter MkI w/MCG-Pro
#10 Cams
#30 Springs
FW: v1.93.F
VKBDevconfig: v0.85.29
Zbootloader: v1. 13

CPU: i7-6700-K
GPU: MSI 1060 6GB GamingX
Mem: 16GB Corsair Vengeance
PSU: Corsair ZX1000
Mobo: Asus P8Z68 Deluxe
Win7/64

mahoffm2
Posts: 4
Joined: Wed Jan 03, 2018 6:14

Re: Flashing red BB Stick LED w/ MCG-Pro grip

Postby mahoffm2 » Wed Jan 03, 2018 7:31

I had to go into the VKB device config then to the global tab were I set the external device from K12 to MCG. Then hit the Set button under action tab at the top. This got the grip recognized. From there I am still struggling.

Drano
Posts: 47
Joined: Sun Oct 01, 2017 5:00
Location: USA, East coast
Has thanked: 1 time
Been thanked: 8 times

Re: Flashing red BB Stick LED w/ MCG-Pro grip

Postby Drano » Wed Jan 03, 2018 7:44

Cool! That at least got the stick light to green. I'm still seeing the small red LED on the PCB so now I'm guessing this is normal. I'm with you then. Chipping away at the next steps. Thanks much!
Gunfighter MkI w/MCG-Pro
#10 Cams
#30 Springs
FW: v1.93.F
VKBDevconfig: v0.85.29
Zbootloader: v1. 13

CPU: i7-6700-K
GPU: MSI 1060 6GB GamingX
Mem: 16GB Corsair Vengeance
PSU: Corsair ZX1000
Mobo: Asus P8Z68 Deluxe
Win7/64

nneeee
Posts: 9
Joined: Tue Sep 06, 2016 12:34
Has thanked: 1 time

MCG Pro Mk1 with Gunfighter Base - need config

Postby nneeee » Wed Jan 03, 2018 10:17

Does anyone know where I can get the profile for the MCG Pro?

nneeee
Posts: 9
Joined: Tue Sep 06, 2016 12:34
Has thanked: 1 time

Re: Flashing red BB Stick LED w/ MCG-Pro grip

Postby nneeee » Wed Jan 03, 2018 10:38

I just posted asking for the MCG Pro profile, then I saw your post.

I'm in the same boat. I have MCG Pro MK1 with Gunfighter base MK1.

I noticed that people posting screenshots of VKBdevcfg show the stick that is recognised as

VKBsim Gunfighter Modern Combat Pro v1.917

whereas mine just says

Vkbsim Black Box GF v1.852

Figured that loading MCG loads the non-pro MCG and it doesn't yet have the Pro cfg file, which is why I think the analog axis are not detected.

User avatar
AeroGator
Posts: 325
Joined: Wed May 31, 2017 7:40
Has thanked: 74 times
Been thanked: 133 times

Re: Flashing red BB Stick LED w/ MCG-Pro grip

Postby AeroGator » Wed Jan 03, 2018 13:35

First, 3 thanks :)
1 - for bringing this to our attention;
2 - for helping us in creating a Knowledge Base (many more MCG users will thank you later on);
3 - for trying to keep yourselves afloat and even finding some solutions while we are lingering...
but we will not linger long.
I will be back quite soon with some advice.
Hold on.
Best Regards,
AeroGator

User avatar
AeroGator
Posts: 325
Joined: Wed May 31, 2017 7:40
Has thanked: 74 times
Been thanked: 133 times

Re: Flashing red BB Stick LED w/ MCG-Pro grip

Postby AeroGator » Wed Jan 03, 2018 14:01

Drano wrote:Firmware : 1.85F

Right. This is it. 1.85F was released in.... what was that... May 2017?
Here I have to apologize and only ask you to wait till tomorrow, tops the day after. But tomorrow is more likely.
The grips are reaching the users faster than we expected. We are writing the firmware on the fly and thought we'd finish before you guys get the grips.
Luckily, or unluckily, it turned out the other way.
So, what you need is 1.917. We will roll it out as I said, probably tmrw.

mahoffm2 wrote:I had to go into the VKB device config then to the global tab were I set the external device from K12 to MCG

We need more information, please check http://forum.vkb-sim.pro/viewtopic.php?f=25&t=2762 for what we need to help you.
Please answer ALL relevant questions. For now I only know you have an MCG, not even its version.
Once again, please don't save 2 minutes on skipping the questions - answer all that are relevant to your device (not to the situation! to the device!).

nneeee wrote:Figured that loading MCG loads the non-pro MCG and it doesn't yet have the Pro cfg file, which is why I think the analog axis are not detected.

Bingo! You managed to dig this deep. A great engineering mind. Yes you are right. Let me just quote what I wrote a few paragraphs above:
Here I have to apologize and only ask you to wait till tomorrow, tops the day after. But tomorrow is more likely.
The grips are reaching the users faster than we expected. We are writing the firmware on the fly and thought we'd finish before you guys get the grips.
Luckily, or unluckily, it turned out the other way.
So, what you need is 1.917. We will roll it out as I said, probably tmrw.

So guys - you r problem is our fault. Don't judge us too strictly. We will cover for it.
I will update this topic when the FW is out. Check throughout tomorrow.
Best Regards,
AeroGator

User avatar
AeroGator
Posts: 325
Joined: Wed May 31, 2017 7:40
Has thanked: 74 times
Been thanked: 133 times

Re: MCG Pro - mapping ministick and brake axes

Postby AeroGator » Wed Jan 03, 2018 14:32

Delynne wrote:I just got my MCG Pro for my Gunfighter, and I'm trying to set it up, but I'm having issues

In future please ALWAYS follow these guidelines: http://forum.vkb-sim.pro/viewtopic.php?f=25&t=2762.
For now - yes I know. Your problem will be solved tomorrow, max the day after. Sorry it is our fault, we were a bit late - didn't expect the mail operators to deliver the grips so fast, thought we still had a day.
Keep your eye on this topic: http://forum.vkb-sim.pro/viewtopic.php?f=25&t=2885
I will merge yours with it.
Best Regards,
AeroGator

mahoffm2
Posts: 4
Joined: Wed Jan 03, 2018 6:14

Re: MCG Pro - mapping ministick and brake axes

Postby mahoffm2 » Wed Jan 03, 2018 20:01

Thank you for your fast response to our inquiries! It's a great product just a little frustrating to use right now but I am sure it will get better. I will pay closer attention to the guidelines in the future. Look forward to the update.

Drano
Posts: 47
Joined: Sun Oct 01, 2017 5:00
Location: USA, East coast
Has thanked: 1 time
Been thanked: 8 times

Re: MCG Pro - mapping ministick and brake axes

Postby Drano » Wed Jan 03, 2018 20:30

Yeah it was a relief actually when the stick light went from red flashing to green. At that point I had a feeling these things weren't all speaking the same language. Good to know it's just a software glitch. You'll straighten it out. Thanks for getting back to us.
Gunfighter MkI w/MCG-Pro
#10 Cams
#30 Springs
FW: v1.93.F
VKBDevconfig: v0.85.29
Zbootloader: v1. 13

CPU: i7-6700-K
GPU: MSI 1060 6GB GamingX
Mem: 16GB Corsair Vengeance
PSU: Corsair ZX1000
Mobo: Asus P8Z68 Deluxe
Win7/64

SpaceJake
Posts: 10
Joined: Wed Jan 03, 2018 23:02
Has thanked: 3 times

Mcp Pro multi-button issue

Postby SpaceJake » Thu Jan 04, 2018 0:10

Hello, I just recieved the Mcp Pro for the Gunfighter Mk1.

I have a few issues, loose grip base, axis not responding in VkbConfig but my main issue is multi-button activation.

I press button 15 [Red] and button 1 [centre hat switch] also activates.

Vkb Joytest1.PNG

Vkb Joytest2.PNG


Also, when I move the stick around while holding button 15 [Red], button 13 [centre button on rightside hatswitch] activates intermittently.

Any help would be appreciated.

Thank you.

Gunfighter Mk1
Mcp Pro [original 3pin]
BB firmware 1.852
VkbConfig software 0.83.85
Springs 30
No centre cams

User avatar
AeroGator
Posts: 325
Joined: Wed May 31, 2017 7:40
Has thanked: 74 times
Been thanked: 133 times

Re: Mcp Pro multi-button issue

Postby AeroGator » Thu Jan 04, 2018 7:13

SpaceJake wrote:Hello, I just recieved the Mcp Pro for the Gunfighter Mk1.
(.......)
Gunfighter Mk1
Mcp Pro [original 3pin]
BB firmware 1.852
VkbConfig software 0.83.85
Springs 30
No centre cams

Thanks Jake for a properly asked question (pictures and system info).
It is a known FW issue, will be fixed today.
I am moving your posts to a dedicated thread to un-clutter the forum.
You can see it here: http://forum.vkb-sim.pro/viewtopic.php?f=25&t=2885
Best Regards,
AeroGator


Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 2 guests