Defender Cobra M5 twist and throttle not recognized by Star Citizen

Moderator: AdminGroup

Magniankh
Posts: 4
Joined: Fri Jan 27, 2017 22:49
Been thanked: 2 times

Defender Cobra M5 twist and throttle not recognized by Star Citizen

Postby Magniankh » Sat Feb 11, 2017 20:26

Hello everyone, as the title says the twist axis and the throttle on the Cobra M5 is not recognized by Star Citizen.
As far as I know, every Star Citizen player that has tried a Cobra M5 has this problem. This has been an issue with the game since 2014 -- the game used to detect the joystick properly, but since a patch in 2014 that's no longer the case.

Some people use vjoy and UJR to get around this problem and get the stick working. I do not want to run two additional pieces of software just to get an axis to work with the stick; that's excessive and obnoxious to load the softwares everytime I wish to play.

When I calibrate the joystick in windows, all axes and buttons are recognized. I also used the rev. B configurator and noticed that the twist axis is actually considered "rz" and not "z." I can successfully map buttons in the key bindings of Star Citizen by editing the .xml file. The binding for twist reads - "rz." (I have also tried simply "z"). The problem is that the game itself fails to respond to the input.

My question is: Is there anything that I can do to the joystick itself? Can someone help me understand what it is about the Cobra M5 in particular that Star Citizen does not like? Knowing what the problem is may help the developers of Star Citizen find a solution.

Thanks.

Return to “Technical Support”

Who is online

Users browsing this forum: No registered users and 1 guest